summaryrefslogtreecommitdiffstatshomepage
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..410ee68
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,32 @@
+moddir=$(prefix)/share/guile/site
+
+SOURCES = \
+ tekuti/base64.scm \
+ tekuti/boot.scm \
+ tekuti/comment.scm \
+ tekuti/config.scm \
+ tekuti/filters.scm \
+ tekuti/git.scm \
+ tekuti/index.scm \
+ tekuti/match-bind.scm \
+ tekuti/mod-lisp.scm \
+ tekuti/page-helpers.scm \
+ tekuti/page.scm \
+ tekuti/post.scm \
+ tekuti/request.scm \
+ tekuti/tags.scm \
+ tekuti/template.scm \
+ tekuti/url.scm \
+ tekuti/util.scm \
+ tekuti/web.scm
+
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES) $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+
+CLEANFILES = $(GOBJECTS)
+
+SUFFIXES = .scm .go
+.scm.go:
+ $(top_builddir)/env $(GUILE_TOOLS) compile -o "$@" "$<"