summaryrefslogtreecommitdiffstatshomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Andy Wingo2010-10-14 16:24:28 +0200
committerGravatar Andy Wingo2010-11-13 18:48:18 +0100
commit4f62c95bdef6907b3f25d278824f0072940b01c7 (patch)
tree2a81eb602d363c09fc39d6f62f1554ba1bcdb7c8 /Makefile.am
parent10095abd4840a8c5d21feea8aea477d5f7aa1df7 (diff)
downloadtekuti-4f62c95bdef6907b3f25d278824f0072940b01c7.tar.gz
tekuti-4f62c95bdef6907b3f25d278824f0072940b01c7.zip
autotoolize, and compile the scheme files
* .gitignore: * AUTHORS: * COPYING: * ChangeLog: * Makefile.am: * NEWS: * README: * acinclude.m4: * configure.ac: * env.in: All the needed bits.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..410ee68
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,32 @@
+moddir=$(prefix)/share/guile/site
+
+SOURCES = \
+ tekuti/base64.scm \
+ tekuti/boot.scm \
+ tekuti/comment.scm \
+ tekuti/config.scm \
+ tekuti/filters.scm \
+ tekuti/git.scm \
+ tekuti/index.scm \
+ tekuti/match-bind.scm \
+ tekuti/mod-lisp.scm \
+ tekuti/page-helpers.scm \
+ tekuti/page.scm \
+ tekuti/post.scm \
+ tekuti/request.scm \
+ tekuti/tags.scm \
+ tekuti/template.scm \
+ tekuti/url.scm \
+ tekuti/util.scm \
+ tekuti/web.scm
+
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES) $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+
+CLEANFILES = $(GOBJECTS)
+
+SUFFIXES = .scm .go
+.scm.go:
+ $(top_builddir)/env $(GUILE_TOOLS) compile -o "$@" "$<"