summaryrefslogtreecommitdiffstats
path: root/linux-drd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux-drd/PKGBUILD')
-rw-r--r--linux-drd/PKGBUILD62
1 files changed, 8 insertions, 54 deletions
diff --git a/linux-drd/PKGBUILD b/linux-drd/PKGBUILD
index 4b02074..cbb7d00 100644
--- a/linux-drd/PKGBUILD
+++ b/linux-drd/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 213943 2014-06-01 05:53:19Z tpowa $
+# $Id: PKGBUILD 214390 2014-06-08 20:30:39Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-drd # Build kernel with a different name
-_srcname=linux-3.14
-pkgver=3.14.5
+_srcname=linux-3.15
+pkgver=3.15
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -13,39 +13,22 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
- "https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+ #"https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
- '0001-Bluetooth-allocate-static-minor-for-vhci.patch'
- '0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch'
- '0003-module-remove-MODULE_GENERIC_TABLE.patch'
- '0005-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch'
- '0006-genksyms-fix-typeof-handling.patch'
- '0010-iwlwifi-mvm-delay-enabling-smart-FIFO-until-after-be.patch'
- '0011-kernfs-fix-removed-error-check.patch'
'0012-fix-saa7134.patch'
- '0015-fix-xsdt-validation.patch'
- 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.14'
+ 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.15'
# 'aufs3-mmap.patch'
)
-sha256sums=('61558aa490855f42b6340d1a1596be47454909629327c49a5e4e10268065dffa'
- 'ecc00856830c05736b3f99609bc6d80353c29d2db9b0dffb91eb2d169808cac4'
- 'c01d212694eddcf694c55e0943bf3336b6e1ff41b90ac1cdc88b26789785ed45'
+sha256sums=('c3927e87be4040fa8aca1b58663dc0776aaf00485604ff88a623be2f3fb07794'
+ 'f6e8770188314d953c42dc929f4a6d91ce3a18375d49d673969aaf5c3eb2924a'
'58907e9c82a97471aa97313a236b7c717e8c1c635e2be7b78bab34cad4617a22'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182'
- '6d72e14552df59e6310f16c176806c408355951724cd5b48a47bf01591b8be02'
- '52dec83a8805a8642d74d764494acda863e0aa23e3d249e80d4b457e20a3fd29'
- '65d58f63215ee3c5f9c4fc6bce36fc5311a6c7dbdbe1ad29de40647b47ff9c0d'
- '3fffb01cf97a5a7ab9601cb277d2468c0fb1e1cceba4225915f3ffae3a5694ec'
- 'cf2e7a2d00787f754028e7459688c2755a406e632ce48b60952fa4ff7ed6f4b7'
- 'c0af4622f75c89fef62183e18b7d49998228d4eaa906c6accaf4aa4ff0134f85'
- '04f44bf5c181d6dc31905937c1bdccb0f5aecaad3a579e99b302502b9cbe0f7a'
'79359454c9d8446eb55add2b1cdbf8332bd67dafb01fefb5b1ca090225f64d18'
- '384dd13fd4248fd6809da8c6ae29ced55d4a5cacc33ac2ae7522093ec0fb26d4'
'SKIP')
_kernelname=${pkgbase#linux}
@@ -54,7 +37,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- patch -p1 -i "${srcdir}/patch-${pkgver}"
+ #patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -64,40 +47,11 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # Fix vhci warning in kmod (to restore every kernel maintainer's sanity)
- patch -p1 -i "${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch"
-
- # Fix atkbd aliases
- patch -p1 -i "${srcdir}/0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch"
- patch -p1 -i "${srcdir}/0003-module-remove-MODULE_GENERIC_TABLE.patch"
-
- # Disable usb autosuspend for intel btusb
- # See http://www.spinics.net/lists/kernel/msg1716461.html
- # Until a solution is found, make sure the driver leaves autosuspend alone
- patch -p1 -i "${srcdir}/0005-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch"
-
- # Fix generation of symbol CRCs
- # http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=dc53324060f324e8af6867f57bf4891c13c6ef18
- patch -p1 -i "${srcdir}/0006-genksyms-fix-typeof-handling.patch"
-
- # https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/iwlwifi-fixes.git/commit/?id=12f853a89e29f50b17698e17e73c328a35f1498d
- # FS#39815
- patch -p1 -i "${srcdir}/0010-iwlwifi-mvm-delay-enabling-smart-FIFO-until-after-be.patch"
-
- # fix Xorg crash with i810 chipset due to wrong removed error check
- # References: http://lkml.kernel.org/g/533D01BD.1010200@googlemail.com
- patch -Np1 -i "${srcdir}/0011-kernfs-fix-removed-error-check.patch"
-
# fix saa7134 video
# https://bugs.archlinux.org/task/39904
# https://bugzilla.kernel.org/show_bug.cgi?id=73361
patch -Np1 -i "${srcdir}/0012-fix-saa7134.patch"
- # fix xsdt validation bug
- # https://bugs.archlinux.org/task/39811
- # https://bugzilla.kernel.org/show_bug.cgi?id=73911
- patch -Np1 -i "${srcdir}/0015-fix-xsdt-validation.patch"
-
## aufs3
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-kbuild.patch"
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-base.patch"