summaryrefslogtreecommitdiffstats
path: root/linux-drd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux-drd/PKGBUILD')
-rw-r--r--linux-drd/PKGBUILD64
1 files changed, 44 insertions, 20 deletions
diff --git a/linux-drd/PKGBUILD b/linux-drd/PKGBUILD
index 61e9bf8..b7818e7 100644
--- a/linux-drd/PKGBUILD
+++ b/linux-drd/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 209775 2014-04-03 22:58:09Z thomas $
+# $Id: PKGBUILD 210212 2014-04-11 22:01:40Z thomas $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
@@ -6,7 +6,7 @@
pkgbase=linux-drd # Build kernel with a different name
_srcname=linux-3.14
pkgver=3.14
-pkgrel=3
+pkgrel=5
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -22,23 +22,31 @@ source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'0001-Bluetooth-allocate-static-minor-for-vhci.patch'
'0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch'
'0003-module-remove-MODULE_GENERIC_TABLE.patch'
- '0004-Revert-syscalls.h-use-gcc-alias-instead-of-assembler.patch'
- '0005-fs-Don-t-return-0-from-get_anon_bdev.patch'
- '0006-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch'
- 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.13'
+ '0004-fs-Don-t-return-0-from-get_anon_bdev.patch'
+ '0005-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch'
+ '0006-genksyms-fix-typeof-handling.patch'
+ '0007-x86-efi-Correct-EFI-boot-stub-use-of-code32_start.patch'
+ '0008-futex-avoid-race-between-requeue-and-wake.patch'
+ '0009-iwlwifi-mvm-rs-fix-search-cycle-rules.patch'
+ '0010-iwlwifi-mvm-delay-enabling-smart-FIFO-until-after-be.patch'
+ 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.14'
# 'aufs3-mmap.patch'
)
sha256sums=('61558aa490855f42b6340d1a1596be47454909629327c49a5e4e10268065dffa'
- '91b05561c96e09c8c3a4ea05fdab0745f578c4bb879feae25f552306bbe6522a'
- '736d0d27d5ddec10fbf2c0ae5f4fb17b041d2b2484af7175bc726898b58ed68a'
+ 'f2131f0f5a20a6cc65a987cf5363d08c343041c859686ceb4bb93d2d2a3d6b34'
+ 'a61e5aecd497d88bd3dc0d7be8c100f8f71095cb465a5ff252612c6a2118cd76'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182'
- 'ad22f6e1a2869730828ddaf93da8b8a748421b7afdd34e1213566985fe7b01dd'
- '29e612a8dda2b2b8af116c16b546a0e1d159f249bfd9628d640cad0f61f0cc4f'
- '555133445de48e781ced3a450bcdf9bfbe4d66b118bbd5b28fea789fa023dd66'
- 'dc1eca93dad93c9c015332d188f5a69508c2077536b8be653d2ff45f1b034941'
- '1f572e748d96403218e846ec469474f557f04d2f5ff137dd2a31fffa193f760e'
- 'a413700adf3b45b7d3c18d2ffed390b9e5769cb361a9a0530f98bfff29fd0aef'
+ '6d72e14552df59e6310f16c176806c408355951724cd5b48a47bf01591b8be02'
+ '52dec83a8805a8642d74d764494acda863e0aa23e3d249e80d4b457e20a3fd29'
+ '65d58f63215ee3c5f9c4fc6bce36fc5311a6c7dbdbe1ad29de40647b47ff9c0d'
+ '1e1ae0f31f722e80da083ecada1f1be57f9ddad133941820c4483b0240e494c1'
+ '3fffb01cf97a5a7ab9601cb277d2468c0fb1e1cceba4225915f3ffae3a5694ec'
+ 'cf2e7a2d00787f754028e7459688c2755a406e632ce48b60952fa4ff7ed6f4b7'
+ 'a98bc3836bcf85774a974a1585e6b64432ba8c42363ee484d14515ccd6a88e24'
+ 'f8699fcf4242c0727c3c0af56928515cef9b6ce329968537ce2894b30d43eade'
+ '1d4c7b24312ed3781e5d139dfb52f0c22350bf5a2845fe747469dfa7b6ed861f'
+ 'c0af4622f75c89fef62183e18b7d49998228d4eaa906c6accaf4aa4ff0134f85'
'SKIP')
_kernelname=${pkgbase#linux}
@@ -64,18 +72,34 @@ prepare() {
patch -p1 -i "${srcdir}/0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch"
patch -p1 -i "${srcdir}/0003-module-remove-MODULE_GENERIC_TABLE.patch"
- # Fix symbols: Revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=83460ec8dcac14142e7860a01fa59c267ac4657c
- # For details, see https://lkml.org/lkml/2014/1/26/22
- patch -p1 -i "${srcdir}/0004-Revert-syscalls.h-use-gcc-alias-instead-of-assembler.patch"
-
# Fix various bugs caused by rootfs having FSID 0
# See http://www.spinics.net/lists/kernel/msg1716924.html
- patch -p1 -i "${srcdir}/0005-fs-Don-t-return-0-from-get_anon_bdev.patch"
+ patch -p1 -i "${srcdir}/0004-fs-Don-t-return-0-from-get_anon_bdev.patch"
# Disable usb autosuspend for intel btusb
# See http://www.spinics.net/lists/kernel/msg1716461.html
# Until a solution is found, make sure the driver leaves autosuspend alone
- patch -p1 -i "${srcdir}/0006-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch"
+ patch -p1 -i "${srcdir}/0005-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch"
+
+ # Fix generation of symbol CRCs
+ # http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=dc53324060f324e8af6867f57bf4891c13c6ef18
+ patch -p1 -i "${srcdir}/0006-genksyms-fix-typeof-handling.patch"
+
+ # Fix the use of code32_start in the EFI boot stub
+ # http://permalink.gmane.org/gmane.linux.kernel/1679881
+ # https://git.kernel.org/cgit/linux/kernel/git/mfleming/efi.git/commit/?h=urgent&id=7e8213c1f3acc064aef37813a39f13cbfe7c3ce7
+ patch -p1 -i "${srcdir}/0007-x86-efi-Correct-EFI-boot-stub-use-of-code32_start.patch"
+
+ # https://git.kernel.org/cgit/linux/kernel/git/stable/stable-queue.git/tree/queue-3.14/futex-avoid-race-between-requeue-and-wake.patch
+ # FS#39806
+ patch -p1 -i "${srcdir}/0008-futex-avoid-race-between-requeue-and-wake.patch"
+
+ # Fix some intel wifi issues
+ # https://git.kernel.org/cgit/linux/kernel/git/stable/stable-queue.git/tree/queue-3.14/iwlwifi-mvm-rs-fix-search-cycle-rules.patch
+ patch -p1 -i "${srcdir}/0009-iwlwifi-mvm-rs-fix-search-cycle-rules.patch"
+ # https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/iwlwifi-fixes.git/commit/?id=12f853a89e29f50b17698e17e73c328a35f1498d
+ # FS#39815
+ patch -p1 -i "${srcdir}/0010-iwlwifi-mvm-delay-enabling-smart-FIFO-until-after-be.patch"
## aufs3
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-kbuild.patch"