summaryrefslogtreecommitdiffstats
path: root/linux-drd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux-drd/PKGBUILD')
-rw-r--r--linux-drd/PKGBUILD23
1 files changed, 5 insertions, 18 deletions
diff --git a/linux-drd/PKGBUILD b/linux-drd/PKGBUILD
index b3506b0..f92ba5c 100644
--- a/linux-drd/PKGBUILD
+++ b/linux-drd/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 216982 2014-07-18 05:19:11Z tpowa $
+# $Id: PKGBUILD 218479 2014-08-01 07:04:34Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-drd # Build kernel with a different name
_srcname=linux-3.15
-pkgver=3.15.6
+pkgver=3.15.8
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -19,17 +19,15 @@ source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
- '0013-efistub-fix.patch'
'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.15'
# 'aufs3-mmap.patch'
)
sha256sums=('c3927e87be4040fa8aca1b58663dc0776aaf00485604ff88a623be2f3fb07794'
- 'f2a15b142cd332c57e71ca06097c1fd159fa0d0709389b9fc10b7f78c48f741b'
- 'ec593326ac4dad420b0b45a472ba3d6be2ce66b9b4d7cccf1453d02d5eb01b19'
- 'ae18091d5ce27bf03942209faa44a9e354f79e0cbbb720a914f94017cdf42102'
+ 'e25557b19dfebc91e42939aa9a62f7a4d4e36ea2cc659368cded51fb2c703456'
+ '2ccde1ef9c80d404f371a9f9f8e2195b1fa9297c0c2017668523c8c2c901cf7d'
+ '761b40d4fe9395c78738d886a055e0da89f858ce11416e7a4caa4283f4a520d6'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182'
- '937dc895b4f5948381775a75bd198ed2f157a9f356da0ab5a5006f9f1dacde5c'
'SKIP')
_kernelname=${pkgbase#linux}
@@ -48,10 +46,6 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # fix efistub hang #33745
- # https://git.kernel.org/cgit/linux/kernel/git/mfleming/efi.git/patch/?id=c7fb93ec51d462ec3540a729ba446663c26a0505
- patch -Np1 -i "${srcdir}/0013-efistub-fix.patch"
-
## aufs3
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-kbuild.patch"
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-base.patch"
@@ -104,13 +98,6 @@ build() {
cat .config > "${startdir}/config.last"
fi
- ####################
- # stop here
- # this is useful to configure the kernel
- #msg "Stopping build"; return 1
- ####################
-
- # build!
make ${MAKEFLAGS} LOCALVERSION= bzImage modules
}