summaryrefslogtreecommitdiffstats
path: root/linux-drd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux-drd/PKGBUILD')
-rw-r--r--linux-drd/PKGBUILD87
1 files changed, 43 insertions, 44 deletions
diff --git a/linux-drd/PKGBUILD b/linux-drd/PKGBUILD
index 4dd7dc9..93e9ea9 100644
--- a/linux-drd/PKGBUILD
+++ b/linux-drd/PKGBUILD
@@ -1,38 +1,54 @@
-# $Id: PKGBUILD 206322 2014-02-23 22:56:33Z thomas $
+# $Id: PKGBUILD 207393 2014-03-08 15:46:53Z thomas $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-drd # Build kernel with a different name
_srcname=linux-3.13
-pkgver=3.13.5
+pkgver=3.13.6
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
-source=(
- "http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
- "http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
- # the main kernel config files
- 'config' 'config.x86_64'
- # standard config files for mkinitcpio ramdisk
- 'linux.preset'
- 'change-default-console-loglevel.patch'
- 'criu-no-expert.patch'
- '0001-sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch'
- '0002-sunrpc-replace-sunrpc_net-gssd_running-flag-with-a-m.patch'
- '0003-nfs-check-if-gssd-is-running-before-attempting-to-us.patch'
- '0004-rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-.patch'
- '0005-sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
- '0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch'
- '0001-SUNRPC-Ensure-that-gss_auth-isn-t-freed-before-its-u.patch'
- '0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch'
- 'i8042-fix-aliases.patch'
- 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.13'
- # 'aufs3-mmap.patch'
-)
+source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
+ "http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+ # the main kernel config files
+ 'config' 'config.x86_64'
+ # standard config files for mkinitcpio ramdisk
+ 'linux.preset'
+ 'change-default-console-loglevel.patch'
+ 'criu-no-expert.patch'
+ '0001-sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch'
+ '0002-sunrpc-replace-sunrpc_net-gssd_running-flag-with-a-m.patch'
+ '0003-nfs-check-if-gssd-is-running-before-attempting-to-us.patch'
+ '0004-rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-.patch'
+ '0005-sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
+ '0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch'
+ '0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch'
+ '0001-Bluetooth-allocate-static-minor-for-vhci.patch'
+ 'i8042-fix-aliases.patch'
+ 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.13'
+ # 'aufs3-mmap.patch'
+ )
+md5sums=('0ecbaf65c00374eb4a826c2f9f37606f'
+ 'a9b131a589a176b4c437b8ca4557b85e'
+ 'ba4468d313adfaf22368add7f58204aa'
+ 'b6c9a6ef0bd8014c57f893a46b26869a'
+ 'eb14dcfd80c00852ef81ded6e826826a'
+ '98beb36f9b8cf16e58de2483ea9985e3'
+ '989dc54ff8b179b0f80333cc97c0d43f'
+ 'dd2adb99cd3feed6f11022562901965c'
+ 'b00cc399d3797cb0793e18b5bf387a50'
+ '7cbd2349cdf046acc37b652c06ba36be'
+ '10dbaf863e22b2437e68f9190d65c861'
+ 'd5907a721b97299f0685c583499f7820'
+ 'a724515b350b29c53f20e631c6cf9a14'
+ 'e6fa278c092ad83780e2dd0568e24ca6'
+ '06f1751777e0772c18c3fa4fbae91aa5'
+ '93dbf73af819b77f03453a9c6de2bb47'
+ 'SKIP')
_kernelname=${pkgbase#linux}
@@ -69,16 +85,15 @@ prepare() {
# http://git.linux-nfs.org/?p=trondmy/linux-nfs.git;a=commitdiff;h=23e66ba97127ff3b064d4c6c5138aa34eafc492f
patch -p1 -i "${srcdir}/0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch"
- # Fix FS#38921
- # http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9eb2ddb48ce3a7bd745c14a933112994647fa3cd
- patch -p1 -i "${srcdir}/0001-SUNRPC-Ensure-that-gss_auth-isn-t-freed-before-its-u.patch"
-
# Fix symbols: Revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=83460ec8dcac14142e7860a01fa59c267ac4657c
patch -Rp1 -i "${srcdir}/0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch"
# Fix i8042 aliases
patch -p1 -i "${srcdir}/i8042-fix-aliases.patch"
+ # Fix vhci warning in kmod (to restore every kernel maintainer's sanity)
+ patch -p1 -i "${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch"
+
## aufs3
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-kbuild.patch"
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-base.patch"
@@ -379,20 +394,4 @@ for _p in ${pkgname[@]}; do
}"
done
-md5sums=('0ecbaf65c00374eb4a826c2f9f37606f'
- '114c391a592131f1c12544e063173a45'
- 'ba4468d313adfaf22368add7f58204aa'
- 'c8643861b5d5b05358fbbf37a48c3e17'
- 'eb14dcfd80c00852ef81ded6e826826a'
- '98beb36f9b8cf16e58de2483ea9985e3'
- '989dc54ff8b179b0f80333cc97c0d43f'
- 'dd2adb99cd3feed6f11022562901965c'
- 'b00cc399d3797cb0793e18b5bf387a50'
- '7cbd2349cdf046acc37b652c06ba36be'
- '10dbaf863e22b2437e68f9190d65c861'
- 'd5907a721b97299f0685c583499f7820'
- 'a724515b350b29c53f20e631c6cf9a14'
- '1ae4ec847f41fa1b6d488f956e94c893'
- 'e6fa278c092ad83780e2dd0568e24ca6'
- '93dbf73af819b77f03453a9c6de2bb47'
- 'SKIP')
+# vim:set ts=8 sts=2 sw=2 et: