summaryrefslogtreecommitdiffstats
path: root/linux-drd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux-drd/PKGBUILD')
-rw-r--r--linux-drd/PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/linux-drd/PKGBUILD b/linux-drd/PKGBUILD
index 3f8cc0f..198cef3 100644
--- a/linux-drd/PKGBUILD
+++ b/linux-drd/PKGBUILD
@@ -1,32 +1,35 @@
-# $Id: PKGBUILD 219302 2014-08-05 04:41:33Z tpowa $
+# $Id: PKGBUILD 219738 2014-08-14 13:48:45Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-drd # Build kernel with a different name
_srcname=linux-3.16
-pkgver=3.16
-pkgrel=2
+pkgver=3.16.1
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
- #"https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
+ 'compal-laptop-hwmon-fix.patch'
'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.16'
# 'aufs3-mmap.patch'
)
sha256sums=('4813ad7927a7d92e5339a873ab16201b242b2748934f12cb5df9ba2cfe1d77a0'
- '487dc1fd428b5793f4f5216fd76bd3640b12c50ea52c6fb909da24baf3612d9b'
- 'f51791da092698afbf96bf14f24881200855b7442269f04db48d6712066ba304'
+ 'd2bf33289acf5c05b57aaca1fd8bb1935ac280c5c4090874e84806d35e17012e'
+ '060a07957201a04faa98b13e99a260c326c76660cb0dc7a724f644dabfae9eff'
+ '45bdf0f1e9df616e1bad3d50f57f8e64b67fba2f9e77617d9a297c495dc7a283'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
+ 'f36f61a0a72bcb0a9c04264343503bfbf927c9ea0db819e66734a3933b060588'
'SKIP')
_kernelname=${pkgbase#linux}
@@ -35,7 +38,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -45,6 +48,9 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
+ # #41458 fix hwmon for compal-laptop module
+ patch -p1 -i "${srcdir}/compal-laptop-hwmon-fix.patch"
+
## aufs3
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-kbuild.patch"
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-base.patch"