summaryrefslogtreecommitdiffstats
path: root/linux-drd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux-drd/PKGBUILD')
-rw-r--r--linux-drd/PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/linux-drd/PKGBUILD b/linux-drd/PKGBUILD
index 0c1bbef..84afe8b 100644
--- a/linux-drd/PKGBUILD
+++ b/linux-drd/PKGBUILD
@@ -5,7 +5,7 @@
# pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-drd # Build kernel with a different name
_srcname=linux-3.17
-pkgver=3.17
+pkgver=3.17.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -13,7 +13,7 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
- #"https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -23,8 +23,9 @@ source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'aufs3-mmap.patch'
)
sha256sums=('f5153ec93c5fcd41b247950e6a9bcbc63fa87beafd112c133a622439a0f76251'
- 'a66e1cab5c41a83fb0e9e04dfa5c7097ab3ca61aa03a50bc5c67390d859c4c3a'
- 'ac858029381a033a976442514abc46a5e0fea703c078433e57960c9a51209ecb'
+ '3b0651951cdc0a81a69b46db99239bc9f00d6a5ae403e0e41c7a1cc177544ec2'
+ '0f1cd431115a2ce84629298d054d5e6f6e78095a3aeda4d1335740c9402efb7e'
+ '4760f61a29c4a103b4f41ce7f46280947ddd047e33879b9a70e5d977d19d12bd'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'SKIP'
@@ -36,7 +37,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- # patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git