summaryrefslogtreecommitdiffstats
path: root/cl-babel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cl-babel/PKGBUILD')
-rw-r--r--cl-babel/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/cl-babel/PKGBUILD b/cl-babel/PKGBUILD
new file mode 100644
index 0000000..7e891b2
--- /dev/null
+++ b/cl-babel/PKGBUILD
@@ -0,0 +1,34 @@
+# http://common-lisp.net/project/babel/releases/babel_0.4.0.tar.gz
+
+_name=babel
+pkgname=cl-$_name
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A charset encoding/decoding library, not unlike GNU libiconv, written in Common Lisp"
+arch=('i686' 'x86_64')
+url="http://common-lisp.net/project/babel/"
+license=('BSD')
+depends=('common-lisp' 'cl-asdf' 'cl-trivial-gray-streams'
+ 'cl-alexandria' 'cl-trivial-features')
+source=(http://common-lisp.net/project/$_name/releases/${_name}_$pkgver.tar.gz)
+md5sums=('6671b21f4bdca262c8a885d46f29db80')
+
+package()
+{
+ local destination="$pkgdir"/usr/share/common-lisp/source/$_name
+ local source="$srcdir"/${_name}_$pkgver
+
+ install -d "$destination"/src
+ install -d "$destination"/tests
+ install -d "$pkgdir"/usr/share/licences/$pkgname
+ install -d "$pkgdir"/etc/common-lisp/source-registry.conf.d/
+
+ install -m 644 "$source"/src/*.lisp "$destination"/src
+ install -m 644 "$source"/tests/*.lisp "$destination"/tests
+ install -m 644 "$source"/*.asd "$destination"
+ install -m 644 "$source"/COPYRIGHT \
+ "$pkgdir"/usr/share/licences/$pkgname
+
+ echo "(:tree \"/usr/share/common-lisp/source/$_name\")" \
+ > "$pkgdir"/etc/common-lisp/source-registry.conf.d/20-$_name.conf
+}