summaryrefslogtreecommitdiffstats
path: root/linux-drd/PKGBUILD
diff options
context:
space:
mode:
authorGravatar Tom Willemse2014-01-20 10:16:08 +0100
committerGravatar Tom Willemse2014-01-20 10:16:08 +0100
commit02803f082d772cf42967bc309e2089e63c44ecdf (patch)
treea08122627cab427ad1214db42a40b6f81d986a59 /linux-drd/PKGBUILD
parent234fb05864ef13f2d6f411e69b013c86ca1e2f6c (diff)
downloadpkgbuilds-02803f082d772cf42967bc309e2089e63c44ecdf.tar.gz
pkgbuilds-02803f082d772cf42967bc309e2089e63c44ecdf.zip
Update linux-drd to 3.12.8
Diffstat (limited to 'linux-drd/PKGBUILD')
-rw-r--r--linux-drd/PKGBUILD67
1 files changed, 47 insertions, 20 deletions
diff --git a/linux-drd/PKGBUILD b/linux-drd/PKGBUILD
index cff16ea..17d19e1 100644
--- a/linux-drd/PKGBUILD
+++ b/linux-drd/PKGBUILD
@@ -1,26 +1,35 @@
-# $Id: PKGBUILD 199010 2013-11-06 08:27:18Z tpowa $
+# $Id: PKGBUILD 204289 2014-01-16 11:42:03Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-drd # Build kernel with a different name
_srcname=linux-3.12
-pkgver=3.12.6
+pkgver=3.12.8
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
-source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
- "http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
- # the main kernel config files
- 'config' 'config.x86_64'
- # standard config files for mkinitcpio ramdisk
- 'linux.preset'
- 'change-default-console-loglevel.patch'
- 'criu-no-expert.patch'
- 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.12')
+source=(
+ "http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
+ "http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+ # the main kernel config files
+ 'config' 'config.x86_64'
+ # standard config files for mkinitcpio ramdisk
+ 'linux.preset'
+ 'change-default-console-loglevel.patch'
+ 'criu-no-expert.patch'
+ 'sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch'
+ 'sunrpc-replace-gssd_running-with-more-reliable-check.patch'
+ 'nfs-check-gssd-running-before-krb5i-auth.patch'
+ 'rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-fails.patch'
+ 'sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
+ 'rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch'
+ 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.12'
+ 'aufs3-mmap.patch'
+)
_kernelname=${pkgbase#linux}
@@ -48,11 +57,22 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
- # # aufs3
+ # fix 15 seocnds nfs delay
+ patch -Np1 -i "${srcdir}/sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch"
+ patch -Np1 -i "${srcdir}/sunrpc-replace-gssd_running-with-more-reliable-check.patch"
+ patch -Np1 -i "${srcdir}/nfs-check-gssd-running-before-krb5i-auth.patch"
+ # fix nfs kernel oops
+ # #37866
+ patch -Np1 -i "${srcdir}/rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-fails.patch"
+ patch -Np1 -i "${srcdir}/sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch"
+
+ patch -Np1 -i "${srcdir}/rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch"
+
+ ## aufs3
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-kbuild.patch"
patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-base.patch"
- patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-mmap.patch"
- # patch -p1 -i "${srcdir}/aufs3-mmap.patch"
+ # patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-mmap.patch"
+ patch -p1 -i "${srcdir}/aufs3-mmap.patch"
cp -R "${srcdir}/aufs3-standalone/Documentation" .
cp -R "${srcdir}/aufs3-standalone/fs" .
cp -R "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" \
@@ -84,8 +104,8 @@ build() {
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
- make menuconfig # CLI menu for configuration
- #make nconfig # new CLI menu for configuration
+ #make menuconfig # CLI menu for configuration
+ make nconfig # new CLI menu for configuration
#make xconfig # X-based configuration
#make oldconfig # using old config from previous kernel version
# ... or manually edit .config
@@ -351,10 +371,17 @@ for _p in ${pkgname[@]}; do
done
md5sums=('cc6ee608854e0da4b64f6c1ff8b6398c'
- '9e75be8b127e58f1a76c0015eabb12ae'
- '798bca5d2f0a1505c9b86a5227a2b339'
- 'a038d66d835bcaa61d3083dde31d56e0'
+ '03d34842e3a1197d17055610f62627b8'
+ 'a9281e90e529795eaf10b45d70ab2868'
+ '04b3adc5c78f9db16dfe8075205d73a0'
'eb14dcfd80c00852ef81ded6e826826a'
'98beb36f9b8cf16e58de2483ea9985e3'
'd50c1ac47394e9aec637002ef3392bd1'
- 'SKIP')
+ 'd4a75f77e6bd5d700dcd534cd5f0dfce'
+ 'dc86fdc37615c97f03c1e0c31b7b833a'
+ '88eef9d3b5012ef7e82af1af8cc4e517'
+ 'cec0bb8981936eab2943b2009b7a6fff'
+ '88d9cddf9e0050a76ec4674f264fb2a1'
+ 'cb9016630212ef07b168892fbcfd4e5d'
+ 'SKIP'
+ 'f1d75b8006daca313788e2f01d6a5465')