summaryrefslogtreecommitdiffstats
path: root/linux-custom/PKGBUILD
diff options
context:
space:
mode:
authorGravatar Tom Willemse2013-10-20 11:56:57 +0200
committerGravatar Tom Willemse2013-10-20 11:56:57 +0200
commitaf79bee4a0c0cbea41bedbd5566f7247c7825879 (patch)
treeca5e7f4903bfb5b2f9b0fddaa1cb0cab3de922f6 /linux-custom/PKGBUILD
parentc4e8d94eadf09db9a0f2475ef6d63c74164b20af (diff)
downloadpkgbuilds-af79bee4a0c0cbea41bedbd5566f7247c7825879.tar.gz
pkgbuilds-af79bee4a0c0cbea41bedbd5566f7247c7825879.zip
Update to linux-3.11.5
Diffstat (limited to 'linux-custom/PKGBUILD')
-rw-r--r--linux-custom/PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/linux-custom/PKGBUILD b/linux-custom/PKGBUILD
index 5eed148..43f729b 100644
--- a/linux-custom/PKGBUILD
+++ b/linux-custom/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 195202 2013-09-27 13:24:39Z tpowa $
+# $Id: PKGBUILD 196514 2013-10-14 16:57:23Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-custom # Build kernel with a different name
_srcname=linux-3.11
-pkgver=3.11.3
+pkgver=3.11.5
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -22,23 +22,14 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'criu-no-expert.patch'
'3.11-haswell-intel_pstate.patch'
'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.11')
-md5sums=('fea363551ff45fbe4cb88497b863b261'
- 'b098457c2d9e9626faacfda931deefb6'
- '247d9bafa184e2d9a27c1a0485419fff'
- '9c891e534bf1dd9df43c5d1deccdcba2'
- 'eb14dcfd80c00852ef81ded6e826826a'
- '98beb36f9b8cf16e58de2483ea9985e3'
- 'd50c1ac47394e9aec637002ef3392bd1'
- '1040ae6c10d4a68f89899f94a2318a17'
- 'SKIP')
_kernelname=${pkgbase#linux}
# module.symbols md5sums
# x86_64
-# 04f5bf482c436b4a75c93754e9eacd8e /lib/modules/3.11.1-1-ARCH/modules.symbols
+# ec2540e9486c8a2c9026a40b8fe551c5 /lib/modules/3.11.5-1-ARCH/modules.symbols
# i686
-# 3414985d965d31f5af7b4ee5c9a2a80d /lib/modules/3.11.1-1-ARCH/modules.symbols
+# e9c1ae7203f65cdd073257640f61505e /lib/modules/3.11.5-1-ARCH/modules.symbols
prepare() {
cd "${srcdir}/${_srcname}"
@@ -58,7 +49,6 @@ prepare() {
# https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/patch/?id=6cdcdb793791f776ea9408581b1242b636d43b37
# will be in 3.12
patch -Np1 -i "${srcdir}/3.11-haswell-intel_pstate.patch"
-
# allow criu without expert option set
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
@@ -365,3 +355,12 @@ for _p in ${pkgname[@]}; do
done
# vim:set ts=8 sts=2 sw=2 et:
+md5sums=('fea363551ff45fbe4cb88497b863b261'
+ '628876a432c0d4090013b383abac20e4'
+ '247d9bafa184e2d9a27c1a0485419fff'
+ '70e07a71ef96935fb4c7518f2edcbf30'
+ 'eb14dcfd80c00852ef81ded6e826826a'
+ '98beb36f9b8cf16e58de2483ea9985e3'
+ 'd50c1ac47394e9aec637002ef3392bd1'
+ '1040ae6c10d4a68f89899f94a2318a17'
+ 'SKIP')