summaryrefslogtreecommitdiffstats
path: root/linux-custom/PKGBUILD
diff options
context:
space:
mode:
authorGravatar Tom Willemse2013-12-01 12:42:35 +0100
committerGravatar Tom Willemse2013-12-01 12:42:35 +0100
commit0e652463d7506780984bfff8c6dfb21887aa2dbe (patch)
tree3365b67d92072be32990c2d5fdf083e1a3a22dec /linux-custom/PKGBUILD
parent41dd0072e6bbcfb01dc4892d9ce3b8d5b529af6c (diff)
downloadpkgbuilds-0e652463d7506780984bfff8c6dfb21887aa2dbe.tar.gz
pkgbuilds-0e652463d7506780984bfff8c6dfb21887aa2dbe.zip
Update linux-custom to 3.12.2
Also remove the AUFS patches because docker should no longer need them.
Diffstat (limited to 'linux-custom/PKGBUILD')
-rw-r--r--linux-custom/PKGBUILD54
1 files changed, 26 insertions, 28 deletions
diff --git a/linux-custom/PKGBUILD b/linux-custom/PKGBUILD
index e8b7aad..22d4cd4 100644
--- a/linux-custom/PKGBUILD
+++ b/linux-custom/PKGBUILD
@@ -5,7 +5,7 @@
# pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-custom # Build kernel with a different name
_srcname=linux-3.12
-pkgver=3.12.1
+pkgver=3.12.2
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -19,9 +19,8 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
- 'criu-no-expert.patch'
- 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.11'
- 'aufs3-mmap.patch')
+ 'criu-no-expert.patch')
+ # 'aufs3-standalone::git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.12')
_kernelname=${pkgbase#linux}
@@ -49,14 +48,14 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
- # aufs3
- patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-kbuild.patch"
- patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-base.patch"
- patch -p1 -i "${srcdir}/aufs3-mmap.patch"
- cp -R "${srcdir}/aufs3-standalone/Documentation" .
- cp -R "${srcdir}/aufs3-standalone/fs" .
- cp -R "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" \
- include/uapi/linux/
+ # # aufs3
+ # patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-kbuild.patch"
+ # patch -p1 -i "${srcdir}/aufs3-standalone/aufs3-base.patch"
+ # patch -p1 -i "${srcdir}/aufs3-mmap.patch"
+ # cp -R "${srcdir}/aufs3-standalone/Documentation" .
+ # cp -R "${srcdir}/aufs3-standalone/fs" .
+ # cp -R "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" \
+ # include/uapi/linux/
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
@@ -330,20 +329,21 @@ _package-docs() {
rm -f "${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile"
}
-_package-api-headers() {
- provides=("linux-api-headers")
- conflicts=("linux-api-headers")
- cd ${srcdir}/${_srcname}
- make INSTALL_HDR_PATH=${pkgdir}/usr headers_install
+# _package-api-headers() {
+# provides=("linux-api-headers")
+# conflicts=("linux-api-headers")
+# cd ${srcdir}/${_srcname}
+# make INSTALL_HDR_PATH=${pkgdir}/usr headers_install
- # use headers from libdrm
- rm -r ${pkgdir}/usr/include/drm
+# # use headers from libdrm
+# rm -r ${pkgdir}/usr/include/drm
- # clean-up unnecessary files generated during install
- find ${pkgdir} \( -name .install -o -name ..install.cmd \) -delete
-}
+# # clean-up unnecessary files generated during install
+# find ${pkgdir} \( -name .install -o -name ..install.cmd \) -delete
+# }
-pkgname=("${pkgbase}" "${pkgbase}-headers" "${pkgbase}-docs" "${pkgbase}-api-headers")
+# "${pkgbase}-api-headers"
+pkgname=("${pkgbase}" "${pkgbase}-headers" "${pkgbase}-docs")
for _p in ${pkgname[@]}; do
eval "package_${_p}() {
_package${_p#${pkgbase}}
@@ -351,11 +351,9 @@ for _p in ${pkgname[@]}; do
done
md5sums=('cc6ee608854e0da4b64f6c1ff8b6398c'
- '5a8cb5a659baeeb6df3fe22de8d32df6'
+ '97453b56d6a999b5a4b0899b4e28fabe'
'798bca5d2f0a1505c9b86a5227a2b339'
- 'a1e4ffedb8450272f54e68e3472c4537'
+ '837191e0b87a64015d37862ecef3ea73'
'eb14dcfd80c00852ef81ded6e826826a'
'98beb36f9b8cf16e58de2483ea9985e3'
- 'd50c1ac47394e9aec637002ef3392bd1'
- 'SKIP'
- 'e4ccb83b7a4d75f4aaddba4c34aca4d9')
+ 'd50c1ac47394e9aec637002ef3392bd1')