summaryrefslogtreecommitdiffstats
path: root/emacs-git/PKGBUILD
diff options
context:
space:
mode:
authorGravatar Tom Willemse2014-11-15 13:56:41 +0100
committerGravatar Tom Willemse2014-11-15 13:56:41 +0100
commit8cb9f192d3835471a7c6a5ee64112fbba2f9fc65 (patch)
tree3351ff72f7ec70d6b474a3202d2bc7b0a41043c4 /emacs-git/PKGBUILD
parent08655112ff5f57bc3a35881d89094da8ac3c6396 (diff)
downloadpkgbuilds-8cb9f192d3835471a7c6a5ee64112fbba2f9fc65.tar.gz
pkgbuilds-8cb9f192d3835471a7c6a5ee64112fbba2f9fc65.zip
Rename emacs-bzr to emacs-git
Use the new official git repository instead of the old bzr repository.
Diffstat (limited to 'emacs-git/PKGBUILD')
-rw-r--r--emacs-git/PKGBUILD79
1 files changed, 79 insertions, 0 deletions
diff --git a/emacs-git/PKGBUILD b/emacs-git/PKGBUILD
new file mode 100644
index 0000000..b0d39ae
--- /dev/null
+++ b/emacs-git/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Neil Santos <nsantos16+aur@gmail.com>
+
+# Emacs is leaking like a sieve on my box with the default values;
+# this should be the number of bytes Emacs should allocate for pure
+# storage (see Elisp manual). Default as of writing this is 1.62 megs
+# (not the final value; there are still calculations done on it).
+_opt_puresize="1820000"
+
+pkgname=emacs-git
+pkgver=20141016
+pkgrel=1
+pkgdesc='The extensible, customizable, self-documenting real-time display editor from its official Git repository'
+arch=('i686' 'x86_64')
+url='http://www.gnu.org/software/emacs/'
+license=('GPL3')
+depends=('dbus-core' 'desktop-file-utils' 'libpng' 'libtiff' 'librsvg'
+ 'giflib' 'libxaw' 'libxpm' 'libjpeg>=7' 'hicolor-icon-theme'
+ 'imagemagick' 'libotf' 'm17n-lib')
+makedepends=('git' 'pkgconfig' 'texinfo')
+provides=("emacs=$pkgver")
+conflicts=('emacs' 'emacs-nox' 'emacs-otf' 'emacs-cvs' 'emacs-bzr')
+install=$pkgname.install
+source=("git+http://git.savannah.gnu.org/r/emacs.git"
+ 'docstrings2.patch')
+
+_mandir=/usr/share/man
+
+pkgver() {
+ cd "$srcdir"/"$_name"
+ git log -1 --pretty=format:"%cd" --date=short | sed s/-//g
+}
+
+build() {
+ cd "$srcdir"/emacs
+ msg "Adjusting BASE_PURESIZE to avoid possible leaks"
+ sed -i -e "s/\(define BASE_PURESIZE\s*(*\)[0-9]*/\1${_opt_puresize}/" \
+ src/puresize.h
+
+ export LDFLAGS="`pkg-config --libs MagickWand`"
+
+ ./autogen.sh || return 1
+ ac_cv_lib_gif_EGifPutExtensionLast=yes ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --mandir=${_mandir} \
+ --without-sound \
+ --with-xft \
+ --without-gif \
+ --without-gconf \
+ --without-gsettings \
+ --with-x-toolkit=lucid || return 1
+ patch -p0 -i "$srcdir"/docstrings2.patch || return 1
+ make bootstrap
+}
+
+package() {
+ cd "$srcdir"/emacs
+ make DESTDIR=${pkgdir} install
+
+ msg "Cleaning up..."
+ mv $pkgdir/usr/bin/{ctags,ctags.emacs}
+ mv $pkgdir/usr/bin/{etags,etags.emacs}
+ mv $pkgdir${_mandir}/man1/{etags.1,etags.emacs.1}.gz
+ mv $pkgdir${_mandir}/man1/{ctags.1,ctags.emacs.1}.gz
+
+ # This is mostly superfluous, and conflicts with texinfo
+ rm $pkgdir/usr/share/info/info.info.gz
+ rm $pkgdir/usr/share/info/dir
+
+ find $pkgdir/usr/share/emacs -type d -exec chmod 755 {} \;
+ find $pkgdir/usr/share/emacs -exec chown root.root {} \;
+ chmod 775 $pkgdir/var/games
+ chmod 775 $pkgdir/var/games/emacs
+ chmod 664 $pkgdir/var/games/emacs/*
+ chown -R root:50 $pkgdir/var/games
+}
+md5sums=('SKIP'
+ '3a868e5b80d5912ded06e6bdc040208a')