summaryrefslogtreecommitdiffstats
path: root/cl-trivial-features/PKGBUILD
diff options
context:
space:
mode:
authorGravatar Tom Willemse2013-06-05 01:20:48 +0200
committerGravatar Tom Willemse2013-06-05 01:20:48 +0200
commit2ded9907358b7433ca194013677dcc41e39ba3d8 (patch)
treefc6356fca2ca5a30fc94719e5312937d656ff61e /cl-trivial-features/PKGBUILD
parent3bfbac83dca1058a003624e3a81f2edae089844a (diff)
downloadpkgbuilds-2ded9907358b7433ca194013677dcc41e39ba3d8.tar.gz
pkgbuilds-2ded9907358b7433ca194013677dcc41e39ba3d8.zip
Add cl-trivial-features 0.7
Diffstat (limited to 'cl-trivial-features/PKGBUILD')
-rw-r--r--cl-trivial-features/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/cl-trivial-features/PKGBUILD b/cl-trivial-features/PKGBUILD
new file mode 100644
index 0000000..1c87096
--- /dev/null
+++ b/cl-trivial-features/PKGBUILD
@@ -0,0 +1,33 @@
+#
+
+_name=trivial-features
+pkgname=cl-$_name
+pkgver=0.7
+pkgrel=1
+pkgdesc="ensures consistent *FEATURES* across multiple Common Lisp implementations"
+arch=('i686' 'x86_64')
+url="http://www.cliki.net/trivial-features/"
+license=('BSD')
+depends=('common-lisp' 'cl-asdf')
+source=("http://common-lisp.net/~loliveira/tarballs/$_name/${_name}_$pkgver.tar.gz")
+md5sums=('06b2c3ea135b1762e1e3ce8c826d083f')
+
+package()
+{
+ local destination="$pkgdir"/usr/share/common-lisp/source/$_name
+ local source="$srcdir"/${_name}_$pkgver
+
+ install -d "$destination"/src
+ install -d "$destination"/tests
+ install -d "$pkgdir"/usr/share/licences/$pkgname
+ install -d "$pkgdir"/etc/common-lisp/source-registry.conf.d/
+
+ install -m 644 "$source"/src/*.lisp "$destination"/src
+ install -m 644 "$source"/tests/*.lisp "$destination"/tests
+ install -m 644 "$source"/*.asd "$destination"
+ install -m 644 "$source"/COPYRIGHT \
+ "$pkgdir"/usr/share/licences/$pkgname
+
+ echo "(:tree \"/usr/share/common-lisp/source/$_name\")" \
+ > "$pkgdir"/etc/common-lisp/source-registry.conf.d/20-$_name.conf
+}