aboutsummaryrefslogtreecommitdiffstats
path: root/oni/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'oni/packages/python-xyz.scm')
-rw-r--r--oni/packages/python-xyz.scm71
1 files changed, 71 insertions, 0 deletions
diff --git a/oni/packages/python-xyz.scm b/oni/packages/python-xyz.scm
new file mode 100644
index 0000000..46ce4d9
--- /dev/null
+++ b/oni/packages/python-xyz.scm
@@ -0,0 +1,71 @@
+(define-module (oni packages python-xyz)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-build))
+
+(define-public python-docopt-subcommands
+ (package
+ (name "python-docopt-subcommands")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "docopt_subcommands" version))
+ (sha256
+ (base32 "0fi4s9q6cx6mq3w53l0lfr7c4h8n7d20jw316d1paka7jqzw64g5"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-docopt))
+ (native-inputs (list python-hypothesis python-pytest python-twine
+ python-wheel))
+ (home-page "https://github.com/abingham/docopt-subcommands")
+ (synopsis "create subcommand-based CLI programs with docopt")
+ (description "create subcommand-based CLI programs with docopt")
+ (license license:expat)))
+
+(define-public python-ultan
+ (package
+ (name "python-ultan")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ultan" version))
+ (sha256
+ (base32 "1rwka329xmxpa0h9j175gfmw0y8r7axb7bs9v1pp3lzhcbzg23qi"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-docopt-subcommands))
+ (native-inputs (list python-hypothesis python-pytest python-tox))
+ (home-page "https://github.com/sixty-north/ultan")
+ (synopsis "Python name and documentation server")
+ (description "Python name and documentation server")
+ (license license:expat)))
+
+(define-public python-traad
+ (package
+ (name "python-traad")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "traad" version))
+ (sha256
+ (base32 "1mr0cfy4ch7lqvyf5b6sr04l0jgdqjcbgpz7k9h7swrr9ns0mmzk"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-rope python-ultan))
+ (native-inputs (list python-pytest python-tox python-twine python-webtest
+ python-wheel))
+ (home-page "http://github.com/abingham/traad")
+ (synopsis "A JSON+HTTP server for the rope Python refactoring library.")
+ (description
+ "This package provides a JSON+HTTP server for the rope Python refactoring
+library.")
+ (license license:expat)))
+