28 lines
837 B
Bash
28 lines
837 B
Bash
# Maintainer: Parantapa Bhattacharya <pb at parantapa dot net>
|
|
pkgname=ttf-fantasque-sans-git
|
|
pkgver=20140609
|
|
pkgrel=1
|
|
pkgdesc="A font family with a great monospaced variant for programmers."
|
|
arch=('any')
|
|
url="https://github.com/belluzj/fantasque-sans"
|
|
license=('SIL OPEN FONT LICENSE Version 1.1')
|
|
depends=('fontconfig' 'xorg-font-utils')
|
|
makedepends=('git' 'fontforge' 'ttfautohint' 'sfnt2woff' 'ttf2eot')
|
|
install=$pkgname.install
|
|
source=(git+https://github.com/belluzj/fantasque-sans.git)
|
|
md5sums=('SKIP')
|
|
|
|
pkgver() {
|
|
cd "$srcdir/fantasque-sans"
|
|
git log -1 --pretty=format:"%cd" --date=short | sed s/-//g
|
|
}
|
|
|
|
build() {
|
|
cd "${srcdir}/fantasque-sans"
|
|
make
|
|
}
|
|
|
|
package() {
|
|
install -d "${pkgdir}/usr/share/fonts/TTF"
|
|
cp -dpr --no-preserve=ownership "${srcdir}/fantasque-sans/"*.ttf "${pkgdir}/usr/share/fonts/TTF"
|
|
}
|