pkgbuilds/conkeror-git/PKGBUILD
2015-06-22 01:56:56 +02:00

50 lines
1.5 KiB
Bash

# Maintainer: Ivy Foster <joyfulgirl@archlinux.us>
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Heeru Kiyura <M8R-p9i5nh@mailinator.com>
pkgname=conkeror-git
pkgver=20150519
pkgrel=1
pkgdesc="A highly programmable web browser based on Mozilla XULRunner."
arch=('i686' 'x86_64')
url="http://conkeror.mozdev.org/"
license=('MPL' 'GPL' 'LGPL')
depends=('xulrunner' 'desktop-file-utils')
makedepends=('git' 'imagemagick')
provides=(conkeror)
source=('git://repo.or.cz/conkeror.git'
conkeror_gimpfile.xpm
conkeror.sh)
md5sums=('SKIP'
'b592582a5b923db1707615564a95737f'
'11c6c76a2639254754b34a542f1965a1')
install=conkeror-git.install
_gitname=conkeror
pkgver() {
cd "$srcdir/$_gitname"
git log -1 --pretty=format:"%cd" --date=short | sed s/-//g
}
build() {
cd "$srcdir/$_gitname"
make
}
package() {
cd "$srcdir"/${_gitname}
install -d "$pkgdir"/usr/share/{conkeror,man/man1,pixmaps}
cp -a "$srcdir"/${_gitname}/* "$pkgdir"/usr/share/conkeror
install -Dm644 "$pkgdir"/usr/share/conkeror/contrib/man/conkeror.1 \
"$pkgdir"/usr/share/man/man1/conkeror.1
install -Dm644 "$srcdir"/conkeror_gimpfile.xpm "$pkgdir"/usr/share/pixmaps
install -Dm755 "$srcdir"/conkeror.sh "$pkgdir"/usr/bin/conkeror
mv "$pkgdir"/usr/share/conkeror/conkeror-spawn-helper "$pkgdir"/usr/bin
rm "$pkgdir"/usr/share/conkeror/conkeror-spawn-helper.c
rm -r "$pkgdir"/usr/share/conkeror/contrib/man
rm -r "$pkgdir"/usr/share/conkeror/debian
}