32 lines
1 KiB
Bash
32 lines
1 KiB
Bash
#
|
|
|
|
_name=trivial-gray-streams
|
|
_version=2008-11-02
|
|
pkgname=cl-$_name
|
|
pkgver=${_version//-/}
|
|
pkgrel=1
|
|
pkgdesc="Compatibility layer library for gray streams in Common Lisp"
|
|
arch=('i686' 'x86_64')
|
|
url="http://common-lisp.net/project/trivial-gray-streams/"
|
|
license=("BSD")
|
|
depends=('common-lisp' 'cl-asdf')
|
|
source=("http://common-lisp.net/project/cl-plus-ssl/download/$_name-$_version.tar.gz")
|
|
md5sums=('b833a416997315f5632209a4bd825ad8')
|
|
|
|
package()
|
|
{
|
|
local destination="$pkgdir"/usr/share/common-lisp/source/$_name
|
|
local source="$srcdir"/$_name-$_version
|
|
|
|
install -d "$destination"
|
|
install -d "$pkgdir"/usr/share/licenses/$pkgname
|
|
install -d "$pkgdir"/etc/common-lisp/source-registry.conf.d/
|
|
|
|
install -m 644 "$source"/*.lisp "$destination"
|
|
install -m 644 "$source"/*.asd "$destination"
|
|
install -m 644 "$source"/COPYING \
|
|
"$pkgdir"/usr/share/licenses/$pkgname
|
|
|
|
echo "(:directory \"/usr/share/common-lisp/source/$_name\")" \
|
|
> "$pkgdir"/etc/common-lisp/source-registry.conf.d/20-$_name.conf
|
|
}
|