pkgbuilds/cl-trivial-features/PKGBUILD

33 lines
1.1 KiB
Bash

#
_name=trivial-features
pkgname=cl-$_name
pkgver=0.7
pkgrel=1
pkgdesc="ensures consistent *FEATURES* across multiple Common Lisp implementations"
arch=('i686' 'x86_64')
url="http://www.cliki.net/trivial-features/"
license=('BSD')
depends=('common-lisp' 'cl-asdf')
source=("http://common-lisp.net/~loliveira/tarballs/$_name/${_name}_$pkgver.tar.gz")
md5sums=('06b2c3ea135b1762e1e3ce8c826d083f')
package()
{
local destination="$pkgdir"/usr/share/common-lisp/source/$_name
local source="$srcdir"/${_name}_$pkgver
install -d "$destination"/src
install -d "$destination"/tests
install -d "$pkgdir"/usr/share/licences/$pkgname
install -d "$pkgdir"/etc/common-lisp/source-registry.conf.d/
install -m 644 "$source"/src/*.lisp "$destination"/src
install -m 644 "$source"/tests/*.lisp "$destination"/tests
install -m 644 "$source"/*.asd "$destination"
install -m 644 "$source"/COPYRIGHT \
"$pkgdir"/usr/share/licences/$pkgname
echo "(:tree \"/usr/share/common-lisp/source/$_name\")" \
> "$pkgdir"/etc/common-lisp/source-registry.conf.d/20-$_name.conf
}