pkgbuilds/cl-iterate/PKGBUILD

28 lines
827 B
Bash

#
_name=iterate
pkgname=cl-$_name
pkgver=1.4.3
pkgrel=1
pkgdesc="iterate is an iteration construct for Common Lisp."
arch=('i686' 'x86_64')
url="http://common-lisp.net/project/iterate/"
license=('BSD')
depends=('common-lisp' 'cl-asdf')
source=("http://common-lisp.net/project/$_name/releases/$_name-$pkgver.tar.gz")
md5sums=('f7b554e02c37ec3b786c6ba413b3a2e6')
package()
{
local destination="$pkgdir"/usr/share/common-lisp/source/$_name
local source="$srcdir"/$_name-$pkgver
install -d "$destination"
install -d "$pkgdir"/etc/common-lisp/source-registry.conf.d/
install -m 644 "$source"/*.lisp "$destination"
install -m 644 "$source"/*.asd "$destination"
echo "(:directory \"/usr/share/common-lisp/source/$_name\")" \
> "$pkgdir"/etc/common-lisp/source-registry.conf.d/20-$_name.conf
}