pkgbuilds/cl-cffi/PKGBUILD

41 lines
1.5 KiB
Bash

# http://common-lisp.net/project/cffi/releases/cffi_0.11.1.tar.gz
_name=cffi
pkgname=cl-$_name
pkgver=0.12.0
pkgrel=1
pkgdesc="Common Foreign Function Interface for Common Lisp"
arch=('i686' 'x86_64') # 32-bit only? needs gnu/stubs-32.h
url="http://common-lisp.net/project/cffi/"
license=('BSD')
depends=('common-lisp' 'cl-asdf' 'cl-babel' 'cl-alexandria'
'cl-trivial-features')
source=("http://common-lisp.net/project/$_name/releases/${_name}_$pkgver.tar.gz")
package()
{
local destination="$pkgdir"/usr/share/common-lisp/source/$_name
local source="$srcdir"/${_name}_$pkgver
install -d "$destination"/examples
install -d "$destination"/grovel
install -d "$destination"/src
install -d "$destination"/uffi-compat
install -d "$pkgdir"/usr/share/licences/$pkgname
install -d "$pkgdir"/etc/common-lisp/source-registry.conf.d/
install -m 644 "$source"/examples/*.lisp "$destination"/examples
install -m 644 "$source"/grovel/*.lisp "$destination"/grovel
install -m 644 "$source"/grovel/*.h "$destination"/grovel
install -m 644 "$source"/src/*.lisp "$destination"/src
install -m 644 "$source"/uffi-compat/*.lisp \
"$destination"/uffi-compat
install -m 644 "$source"/*.asd "$destination"
install -m 644 "$source"/COPYRIGHT \
"$pkgdir"/usr/share/licences/$pkgname
echo "(:tree \"/usr/share/common-lisp/source/$_name\")" \
> "$pkgdir"/etc/common-lisp/source-registry.conf.d/20-$_name.conf
}
md5sums=('fdde8082a8bc145f61d3c74803b57b7d')