47 lines
1.2 KiB
Bash
47 lines
1.2 KiB
Bash
#
|
|
|
|
_name=alexandria
|
|
pkgname=cl-$_name-git
|
|
pkgver=20130126
|
|
pkgrel=1
|
|
pkgdesc="Common Lisp portability library"
|
|
arch=('i686' 'x86_64')
|
|
url="http://common-lisp.net/project/alexandria/"
|
|
license=('custom:public domain')
|
|
provides=('cl-alexandria')
|
|
conflicts=('cl-alexandria-darcs')
|
|
depends=('common-lisp' 'cl-asdf')
|
|
makedepends=('git')
|
|
source=(git://common-lisp.net/projects/alexandria/alexandria.git)
|
|
md5sums=('SKIP')
|
|
|
|
pkgver()
|
|
{
|
|
cd "$srcdir"/"$_name"
|
|
git log -1 --pretty=format:"%cd" --date=short | sed s/-//g
|
|
}
|
|
|
|
# build()
|
|
# {
|
|
# cd "$srcdir"/$_name/doc
|
|
# make info
|
|
# }
|
|
|
|
package()
|
|
{
|
|
local destination="$pkgdir"/usr/share/common-lisp/source/$_name
|
|
local source="$srcdir"/$_name
|
|
|
|
install -d "$destination"
|
|
install -d "$pkgdir"/usr/share/licenses/$pkgname
|
|
install -d "$pkgdir"/etc/common-lisp/source-registry.conf.d/
|
|
|
|
install -m 644 "$source"/*.lisp "$destination"
|
|
install -m 644 "$source"/*.asd "$destination"
|
|
install -m 644 "$source"/LICENCE \
|
|
"$pkgdir"/usr/share/licenses/$pkgname
|
|
# install -m 644 "$source"/doc/*.info "$pkgdir"/usr/share/info/
|
|
|
|
echo "(:directory \"/usr/share/common-lisp/source/$_name\")" \
|
|
> "$pkgdir"/etc/common-lisp/source-registry.conf.d/20-$_name.conf
|
|
}
|