summaryrefslogtreecommitdiffstatshomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Andy Wingo2010-10-14 16:24:28 +0200
committerGravatar Andy Wingo2010-11-13 18:48:18 +0100
commit4f62c95bdef6907b3f25d278824f0072940b01c7 (patch)
tree2a81eb602d363c09fc39d6f62f1554ba1bcdb7c8 /configure.ac
parent10095abd4840a8c5d21feea8aea477d5f7aa1df7 (diff)
downloadtekuti-4f62c95bdef6907b3f25d278824f0072940b01c7.tar.gz
tekuti-4f62c95bdef6907b3f25d278824f0072940b01c7.zip
autotoolize, and compile the scheme files
* .gitignore: * AUTHORS: * COPYING: * ChangeLog: * Makefile.am: * NEWS: * README: * acinclude.m4: * configure.ac: * env.in: All the needed bits.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..da0d667
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,21 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(tekuti, 0.2.0)
+AC_CONFIG_SRCDIR(src/tekuti)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability])
+AM_SILENT_RULES([yes])
+
+GUILE_PROGS
+
+if $GUILE_TOOLS | grep -q compile; then
+ # everything cool
+ true
+else
+ AC_MSG_ERROR([Guile 2.0 required.])
+fi
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([env], [chmod +x env])
+
+AC_OUTPUT