summaryrefslogtreecommitdiffstatshomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Andy Wingo2010-11-13 18:34:40 +0100
committerGravatar Andy Wingo2010-11-13 18:48:18 +0100
commitda85967b4222ea1c81533311d94d5dc7d7c243f8 (patch)
tree0559ba87e0d60150f61148003dcb1d57e90e8e54 /Makefile.am
parent5b81c576a5cc297bc9b835d5cbd2881aae319f60 (diff)
downloadtekuti-da85967b4222ea1c81533311d94d5dc7d7c243f8.tar.gz
tekuti-da85967b4222ea1c81533311d94d5dc7d7c243f8.zip
use compile warnings
* Makefile.am (GUILE_WARNINGS): Use compile warnings when compiling tekuti.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 410ee68..214334d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,7 @@ EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
CLEANFILES = $(GOBJECTS)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
SUFFIXES = .scm .go
.scm.go:
- $(top_builddir)/env $(GUILE_TOOLS) compile -o "$@" "$<"
+ $(top_builddir)/env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"